Upgrading Dell Embassy Trust Suite by Wave Systems

We have a Dell Latitude D830 laptop that shipped with the above-mentioned software package. It was originally version 2.something. I didn’t note the exact number. I decided to try to update to the latest version, and grabbed Wave-Systems-Corp_EMBASSY-Tr_A04_R217281.exe from support.dell.com. This wanted to create c:\dell\drivers\R217281 (I let it), populated the directory, and then launched the installer.

It failed not long after launching with the following error message in a pop-up dialog box: “The Wave Installer could not upgrade the prerequisite Wave Infrastructure. Reason: Could not run the installer. Fatal error during installation.” I tried uninstalling and reinstalling. Same failure. Also, I could not fully get everything removed from the Add/Remove Programs dialog box. Googling suggested I try ‘msiexec /unregister’ and then ‘msiexec /regserver’ from a command prompt, and then try reinstalling again. I can’t say with certainty but I think it changed the look of the basic installer window and prepended the “Dell” to the name of the software package being installed. This gave me hope, but no dice. Identical error dialog box.

A little more Google time and I learned of the Windows Installer CleanUp Utility. This seems like a ‘kill -9’ version of add/remove programs. I used it on all of the installed components that I judged to be part of this package. It worked quickly and painlessly.

I tried the installer again and everything worked!

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s